Вопрос по информатике:
Паскаль.
На вход программе подаётся натуральное число n<=1000. Выведите количество делителей числа n, включая 1 и само число n. (Помогите пожалуйста)
- 04.02.2018 20:05
- Информатика
- remove_red_eye 12104
- thumb_up 10
Ответы и объяснения 1
begin
var a:=ReadInteger;
writeln(Range(1,a).Where(x->a mod x=0).Count);
end.
Пример:
12
6
- 05.02.2018 03:51
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.