Вопрос по информатике:
Написать программу, которая заполняет массив из 6 элементов случайными неповторяющимися целочисленными значениями от 1 до 49. После этого программа просит пользователя ввести 6 целых чисел от 1 до 49 (при вводе проверяется, что вводимое число соответствует данному условию; в противном случае число вводится повторно). Программа считает, сколько чисел из введённых пользователем оказалась в массиве, и выводит их количество на экран. Паскаль абс срочно без плагеата
Program Loto;
Uses Crt;
Const
lt = 49; (* количество шаров в лототроне *)
shar = 6; (* количество выигрышных шаров*)
Var
lott : array [1..lt] of integer;
i, nom : integer;
Begin
randomize;
for i:=1 to lt do
lott[i]:=i;
i:=1;
while i <= shar do begin
nom := random(49)+1;
if lott[nom] <> 0 then begin
write(lott[nom], ‘ ’);
lott[nom] := 0;
i := i+1;
end;
end;
writeln;
End.
это начало по этой программе сделать
- 04.07.2017 16:59
- Информатика
- remove_red_eye 11884
- thumb_up 20
Ответы и объяснения 1
Uses Crt;
Const lt = 49; (* количество шаров в лототроне *)
shar = 6; (* количество выигрышных шаров*)
Var lott,vyb : array [1..shar] of integer;
i, j, nom, k : integer;
m:set of byte;
Begin
randomize;
m:=[];
for i:=1 to shar do
begin
repeat
nom:=1+random(lt);
until not(nom in m);
lott[i]:=nom;
m:=m+[nom];
end;
writeln('Выберите шаров от 1 до 6 ',lt);
m:=[];
begin
repeat
write('nom',i,'=');
readln(nom);
until (nom in [1..lt])and not(nom in m);
vyb[i]:=nom;
m:=m+[nom];
end;
clrscr;
writeln('Номера шаров в лототроне');
for i:=1 to shar do write(lott[i]:3);
writeln;
writeln('Выбранные шары');
for i:=1 to shar do
write(vyb[i]:3);
writeln;
write('Совпавшие шары: ');
k:=0;
for i:=1 to shar do
for j:=1 to shar do
if lott[i]=vyb[j] then
begin
k:=k+1;
write(lott[i]:3);
end;
if k=0 then write('- нет')
else write(' Их количество=',k)
end.
- 05.07.2017 16:17
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.