Вопрос по информатике:
Известны данные о марках автомобилей и их стоимости(Лада-400тыс,БМВ-700тыс,Шеврале-800тыс,Нисан-1000000).Необходимо обеспечить ввод этих данных в программу,после этого следует найти авто максимально близкий к средней стоимости,вычисленный по всем авто.Написать программу реализующие поставленные задачи
- 12.12.2017 10:02
- Информатика
- remove_red_eye 17777
- thumb_up 13
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
type
tCar=record
brand:string;
cost:real;
end;
begin
var a:=new tCar[4];
for var i:=0 to 3 do begin
var b:=ReadlnString(i+1+') введите марку и стоимость в рублях:').ToWords;
a[i].brand:=b[0]; a[i].cost:=b[1].ToReal;
end;
var m:=a.Select(t->t.cost).Average;
var p:=a.Select(t->Abs(t.cost-m)).ToArray.IndexMin;
Writeln('Выбран автомобиль марки ',a[p].brand,' стоимостью ',a[p].cost)
end.
- 13.12.2017 14:19
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.