Вопрос по информатике:
Паскаль
Составьте программу, которая заполняет одномерный массив двадцатью первыми натуральными числами, кратными 5 или 7. Полученный массив вывести на экран.
- 09.02.2017 03:21
- Информатика
- remove_red_eye 18795
- thumb_up 24
Ответы и объяснения 1
numbers:array [0..19] of integer;
arrayCounter:integer;
begin
counter := 0;
arrayCounter := 0;
repeat
if(counter mod 5 = 0) or (counter mod 7 = 0) then
begin
numbers[arrayCounter] := counter;
Inc(arrayCounter);
end;
Inc(counter);
until arrayCounter = 20;
for var i := 0 to 19 do writeln(numbers[i]);end.
- 01.01.1970 00:00
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.