Вопрос по информатике:
Помогите написать программу на паскале
Даны 2 массива. Элемент одного массива умножить на элемент другого в обратном порядке. Заранее спасибо
- 04.01.2016 20:20
- Информатика
- remove_red_eye 7904
- thumb_up 29
Ответы и объяснения 1
Const
n = 8;
var
a,b: array[1..n] of integer;
i, k, s: integer;
begin
Randomize;
Write('Массив 1: ');
for i := 1 to n do
begin
a[i] := Random(50)+1;
Write(a[i]:5);
end;
Writeln;
Write('Массив 2: ');
for i := 1 to n do
begin
b[i] := Random(50)+1;
Write(b[i]:5);
end;
Writeln;
Write('Результат: ');
for i := 1 to n do Write(a[i]*b[n-i+1]:5);
Writeln
end.
Тестовое решение:
Массив 1: 39 10 14 23 37 38 33 48
Массив 2: 22 45 1 17 16 42 21 39
Результат: 1521 210 588 368 629 38 1485 1056
- 05.01.2016 00:10
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.