Вопрос по информатике:
С клавиатуры вводится 2 угла и 3 стороны треугольника,написать программу,которая определяет вид треугольника(Прямоугольный,Равнобедренный,Равносторонний,Тупо угольный, Остроугольный)На c+
- 07.07.2018 06:07
- Информатика
- remove_red_eye 8126
- thumb_up 14
Ответы и объяснения 1
using namespace std;
int main(){
int Angle1= 0, Angle2 = 0, Angle3;
cin >> Angle1;
cin >> Angle2;
Angle3 = 180 - (Angle1 + Angle2);
if ((Angle1 == 90) | (Angle2 == 90) | (Angle3 == 90))
{
cout << "Pryamougolniy" << endl;
}
if ((Angle1 > 90) | (Angle2 > 90) | (Angle3 > 90))
{
cout << "Tupougolniy" << endl;
}
if ((Angle1 == Angle2) && (Angle2 == Angle3))
{
cout << "Ravnostoronniy" << endl;
}
if (((Angle1 == Angle2) & (Angle2 != Angle3)) | ((Angle1 == Angle3) & (Angle1 != Angle2)) | ((Angle2 == Angle3) & (Angle2 != Angle1)))
{
cout << "Ravnobedrenniy" << endl;
}
system("pause");
}
- 08.07.2018 14:50
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.