Вопрос по информатике:
Срочно нужно написать программу на Pascal. Программа должна выводить 20 случайных чисел от 1 до 26 и чтобы они не повторялись. Числа должны сохранятся в массиве. Заранее Спасибо!
- 21.07.2016 00:42
- Информатика
- remove_red_eye 16571
- thumb_up 48
Ответы и объяснения 1
c,b,i,d: integer;
begin
c:=0;
b:=0;
for i:= 1 to 20 do
begin
a[i]:=random (1,26);
while (b 1) do
begin
for d:= 1 to i-1 do
if (a[i] = a[d]) then c:=1;
if (c = 1) then a[i]:=random (1,26) else b:=1;
c:=0;
end;
end;
for i:= 1 to 20 do
writeln(a[i]);
end.
P.S. Не уверен что правильно,т.к. не могу проверить программу в паскале
- 22.07.2016 23:21
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.