Вопрос по информатике:
PascalABC.net Если можно сделайте по простому.
Вы уже занимаете большое положение в обществе и пора бы вам искать собственного зама. Вы решаете устроить конкурс среди n соискателей. Ваш план - найти молодого человека с высшим образованием и вырастить его в классного специалиста.
На данный момент требования следующие:
Возраст соискателя должен быть больше 22, но меньше 30 лет. Количество лет, проведенных в ВУЗ-е должно быть не менее пяти.
Программа должна определять, есть ли такой соискатель среди n желающих.
Формат входных данных
Вводится целое число n - количество соискателей (1 <= n <= 300)
Вводится n пар целых чисел: age и edu. Где age - возраст соискателя (1 <= age <= 100), edu - количество лет, проведенных в вузе (0 <= edu <= 30).
Формат выходных данных
Выводится сообщение YES, если среди соискателей нашелся хотя бы один, подходящий и NO - если не нашлось ни одного соискателя.
Примеры
входные данные
3
21 8
40 2
25 4
выходные данные
NO
- 07.07.2018 14:38
- Информатика
- remove_red_eye 15446
- thumb_up 13
Ответы и объяснения 1
begin
var n:=ReadInteger;
var age, edu: integer;
var b:=false;
for var i:=1 to n do
begin
(age,edu):=ReadInteger2;
b:=b or (age in [23..29])and(edu>=5);
end;
if b then writeln('YES') else writeln('NO');
end.
Пример:
3
21 8
40 2
25 4
NO
- 08.07.2018 09:56
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.