Вопрос по информатике:
Сколько различных значений числа d можно ввести, чтобы после выполнения программы было напечатано 171?
var n, s, d: integer;
begin
readln(d);
n := 27;
s := 12;
while s <= 2019 do begin
s := s + d;
n := n + 16
end;
write(n)
end.
- 02.04.2018 21:22
- Информатика
- remove_red_eye 13928
- thumb_up 30
Ответы и объяснения 1
27 + 16x = 171
x = 9 - это значит цикл должен выполниться 9 раз.
Чтоб цикл выполнился 9 раз составим неравенство исходя из условия s<=2019:
(2019-12)9 = 223 - это знаит при d=223 цикл выполнится 10 раз (так как при 9 разе s=2019 и цикл выполнится еще раз). Прибавим 1 к 223 и получим начальное значение при котором результат будет 171.
Далее узнаем конечное значение:
(2012-12)/x = 8
x= 250 - это последнее значение, при котором результат будет 171. При d = 251 - не будет 171.
Ответ: [224;250] . Всего 27 значений
- 03.04.2018 01:33
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.