Вопрос по информатике:
РЕШИТЕ ПОЖАЛУЙСТА!!!!!!!!!!
Посудина цилиндрической формы заполнена до краёв водой, d=1200кг/м3.
Составить программу которая вычисляет:
а)давление жидкости на дно посудины по формуле p=dgh(g=9,8м/с2)
б)массу жидкости в каждой посудине m=dV=dhS (S=3,14R2)
в) сумарную массу жидкости
Радиус посудины,высоту столба жидкости нужно вводить с клавиатуры,а результат вывести на экран.
СПАСИБО))))))))
- 08.05.2017 14:43
- Информатика
- remove_red_eye 9372
- thumb_up 90
Ответы и объяснения 1
а)
var
p,d,h:real;
begin
readln(h);
p:=1200*9.8*h;
writeln(p);
end.
б)
var
m,h,r:real;
begin
readln(h);
readln(r);
m:=1200*3.14*h*r*r;
writeln(m);
end;
в) необходимы дополнительные условия количество сосудов
если принять количество сосудов за k тогда
var
i,k:integer;
m,h,r,S:real;
begin
readln(k);
S:=0;
for i:=1 to k do
begin
readln(h);
readln(r);
m:=1200*3.14*h*r*r;
S:=S+m;
end;
writeln(S);
end.
- 09.05.2017 08:32
- thumb_up 54
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.