Вопрос по информатике:
Ребят завтра диагностика! Помогите пожалуйста !!!
16.Автомат получает на вход четырёхзначное десятичное число. По
полученному числу строится новое десятичное число по следующим
правилам.
1. Вычисляются два числа – сумма первой и второй цифр и сумма третьей и
четвёртой цифр заданного числа.
2. Полученные два числа записываются друг за другом в порядке неубывания
(без разделителей).
Пример. Исходное число: 2177. Поразрядные суммы: 3, 14. Результат: 314.
Определите, сколько из приведённых ниже чисел может получиться
в результате работы автомата.
1915 20 101 1213 1312 312 1519 112 1212
В ответе запишите только количество чисел.
10.Известная авиакомпания заносила данные о количестве утерянного багажа за
год в таблицу Lose. Всего были занесены данные за последние 10 лет
работы компании (Lose[1] – количество утерянного багажа за первый год
работы, Lose[2] – за второй год и т. д.). Определите, какое число будет
напечатано в результате работы следующей программы. Текст программы
приведён на трёх языках программирования.
Алгоритмический язык !!!
алг
нач
целтаб Lose[1:10]
цел t, m
Lose[1] := 1; Lose[2] := 5
Lose[3] := 3; Lose[4] := 6
Lose[5] := 7; Lose[6] := 12
Lose[7] := 1; Lose[8] := 3
Lose[9] := 3; Lose[10] := 1
m := 0
нц для t от 1 до 10
если Lose[t] > 3 то
m := m + Lose[t]
все
кц
вывод m
кон
Бейсик!!
DIM Lose(10) AS INTEGER
DIM t,m AS INTEGER
Lose(1) = 1: Lose(2) = 5
Lose(3) = 3: Lose(4) = 6
Lose(5) = 7: Lose(6) = 12
Lose(7) = 1: Lose(8) = 3
Lose(9) = 3: Lose(10) = 1
m = 0
FOR t = 1 TO 10
IF Lose(t) > 3 THEN
m = m + Lose(t)
END IF
NEXT k
PRINT m
Паскаль!
Var t, m: integer;
Lose: array[1..10] of integer;
Begin
Lose[1] := 1; Lose[2] := 5;
Lose[3] := 3; Lose[4] := 6;
Lose[5] := 7; Lose[6] := 12;
Lose[7] := 1; Lose[8] := 3;
Lose[9] := 3; Lose[10] := 1;
m := 0;
For t := 1 to 10 Do
If Lose[t] > 3 Then
Begin
m := m + Lose[t];
End;
Writeln(m);
End.
9.Запишите значение переменной u, полученное в результате работы
следующей программы. Текст программы приведён на трёх языках
программирования.
Алгоритмический язык !!!
алг
нач
цел u,i
u := 30
нц для i от 1 до 6
u := u – i
кц
вывод u
кон
Бейсик!!!
DIM i,u AS INTEGER
u = 30
FOR i = 1 TO 6
u = u – i
NEXT i
PRINT u
Паскаль!!
Var u,i: integer;
Begin
u := 30;
For i := 1 to 6 do
u := u – i;
Writeln(u);
End.
7.Дима хотел послушать музыку на компьютере, для этого ему нужно было
включить музыкальный файл Белые_розы.mp3. Он начал работу с каталога
С:\Музыка\Хиты. Сначала он спустился на один уровень вниз, в каталог
Ретро, затем поднялся на один уровень вверх, потом спустился на один
уровень в каталог Лучшие и нашёл там нужный музыкальный файл.
Запишите полный путь к данному файлу.
1) С:\Музыка\Хиты\Лучшие\Белые_розы.mp3
2) С:\Музыка\Белые_розы.mp3
3) С:\Белые_розы.mp3
4) С:\Музыка\Хиты\Ретро\Белые_розы.mp3
- 27.01.2015 21:58
- Информатика
- remove_red_eye 16361
- thumb_up 18
Ответы и объяснения 1
16. 4 числа:
1915 – не могло: в порядке неубывания число делится на 1 и 915, 915 – не сумма двух цифр
20 – не могло: не делится на два числа в порядке неубывания, только 2 и 0
101 – не могло: не делится на два числа в порядке неубывания, только 10 и 1
1213 – могло, например, для числа 6667
1312 – не могло: в порядке неубывания число делится на 1 и 312, 312 – не сумма двух цифр
312 – могло, например, для числа 1266
1519 – не могло: в порядке неубывания число делится на 1 и 519 или 15 и 19, 519 и 19 – не сумма двух цифр
112 – могло, например, для числа 1066
1212 – могло, например, для числа 6666
10. Дан массив [1, 5, 3, 6, 7, 12, 1, 3, 3, 1].
Изначально m = 0, при обходе массива если элемент Lose[t] больше 3, то к m прибавляется Lose[t].
Значит, после выполнения программы на экране будет напечатана сумма элементов массива, больших трёх. Эта сумма равна 5 + 6 + 7 + 12 = 30.
9. Изначально u = 30. Затем для каждого i от 1 до 6 из u вычитается значение i, после цикла u равно 30 - 1 - 2 - 3 - 4 - 5 - 6 = 9. Это значение будет выведено на экран.
7. Путь Димы: С:\Музыка\Хиты – С:\Музыка\Хиты\Ретро – С:\Музыка\Хиты – С:\Музыка\Хиты\Лучшие
В последней папке он запустил Белые_розы.mp3. Полное имя файла состоит из пути к папке и имени файла:
С:\Музыка\Хиты\Лучшие\Белые_розы.mp3
- 28.01.2015 11:34
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.