Вопрос по информатике:
Даны 4 целых числа. Найти сумму и количество чётных чисел то есть написать программу
- 16.03.2015 05:32
- Информатика
- remove_red_eye 8987
- thumb_up 52
Ответы и объяснения 1
handsfree = false;
nmax = 4;
random_min = -50;
random_max = 50;
var
a: array[1..nmax] of integer;
i, n, j: integer;
sum, product, harmonic: real;
k: integer;
begin
{ввод массива}
n := nmax;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(random_max - random_min) + random_min;
write(a[i], ' ');
end
else
readln(a[i]);
end;
writeln();
{подсчет элементов}
k := 0;
for i := 1 to n do
if a[i] mod 2 = 0 then
k := k + 1;
writeln('quantity = ', k);
{подсчет суммы и произведения и агригатов}
sum := 0;
for i := 1 to n do
sum := sum + a[i];
writeln('sum = ', sum);
end.
- 17.03.2015 13:17
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.