Вопрос по информатике:
Дан целочисленый массив из 75 элементов.элементы массива могут принимать значения от 1000 до 1000.составьте программу,которая находит и выводит среднее арифметическое всех элементов массива,оканчивающихся цифров 5
- 07.07.2018 17:59
- Информатика
- remove_red_eye 5058
- thumb_up 50
Ответы и объяснения 1
program massiv;
uses CRT;
const N=30;
var i,S:integer;
K:real;
a:array [1..N] of integer;
begin поёдёт? пожалуйсто да
for i:=1 to N do
begin
read a[i];
end;
for i:=1 to N do
begin
if a[i] mod 10 =5
then
S:=S+a[i];
K:=K+1;
end;
write(S/K);
readkey;
end.
- 08.07.2018 02:57
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.