Вопрос по информатике:
Здравствуйте. Нужно написать программу на Pascal ABC Net. Суть программы такова, чтобы она рандомно выбирала цвета (красный, чёрный или зелёный), но с определёнными шансами, то есть Красный=43,75%, Чёрный=50% и Зелёный=6,25%. В результате программа должна выдать человеку какой цвет выпадет.
В множество Красного цвета входят числа: 1,5,7,9,11,13,15
В множество чёрных: 2,4,6,8,10,12,14,16
В множество Зелёных: 3.
- 06.08.2015 21:53
- Информатика
- remove_red_eye 10842
- thumb_up 23
Ответы и объяснения 1
begin
var c:=random(1,16);
case c of
1,5,7,9,11,13,15: writeln(c,' - Красный');
2,4,6,8,10,12,14,16: writeln(c,' - Чёрный');
else writeln(c,' - Зелёный');
end;
end.
Пример:
7 - Красный
- 07.08.2015 09:41
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.