Вопрос по информатике:
Написать программу на языке PascalABC, которая умеет выполнять арифметические действия с 5 разными числами и выводит промежуточные и итоговый результаты.
Пример работы программы:
Введите первое число: 4
Выберите первое действие (a) сложить, b) вычесть, c) умножить, d) разделить): a
Введите второе число: 8
Первая операция: 4+8=12
Введите второе действие (a) сложить, b) вычесть, c) умножить, d) разделить): c
Введите третье число: 3
Вторая операция: 12*3=26
.... так до пятого числа и 5 операции
- 09.08.2018 06:29
- Информатика
- remove_red_eye 2845
- thumb_up 8
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=Arr('первое', 'второе','третье','четвертое','пятое');
var p,r:real;
var c:char;
Write('Введите первое число: '); Readln(r);
for var i:=0 to 3 do begin
Write('Выберите ',s[i], ' действие (a) сложить, b) вычесть,');
Write('c) умножить, d) разделить): '); Readln(c);
Write('Введите ',s[i+1],' число: '); Readln(p);
case c of
'a':r+=p;
'b':r-=p;
'c':r*=p;
'd':r/=p;
end;
Writeln('Результат: ',r)
end
end.
- 01.01.1970 00:00
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.