Вопрос по информатике:
Написать программу с помощью операторы if. Оператор for применять не требуется.
Ладья бьет либо строго вертикально на любой клетке, либо строго горизонтально. В этом случае меняется у фигуры либо только координата X(номер строки), либо только координата Y(номер столбца).
Требуется определить, бьет ли ладья, стоящая на клетке с указанными координатами (номер строки и номер столбца), фигуру, стоящую на другой указанной клетке.
Входные данные
Вводятся четыре числа: координаты ладьи (два числа) и координаты другой фигуры (два числа), каждое число вводится в отдельной строке. Координаты - целые числа в интервале от 1 до 8.
Выходные данные
Требуется вывести слово YES, если ладья сможет побить фигуру за 1 ход и NO - в противном случае.
Примеры
Входные данные
1
1
2
2
Выходные данные
NO
Входные данные
1
1
2
1
Выходные данные
YES
- 15.08.2016 17:30
- Информатика
- remove_red_eye 15902
- thumb_up 23
Ответы и объяснения 1
x1,y1,x2,y2:byte;
Begin
Read(x1,y1,x2,y2);
if (x1-x2 = 0)xor(y1-y2 = 0) then Write('YES')
else Write('NO')
End.
- 16.08.2016 07:17
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.