Вопрос по информатике:
Написать программу полностью. СРОЧНО (Паскаль)
"Найти индексы тех элементов массива, у которых значение больше, чем значение предыдущего элемента"
- 23.01.2018 06:19
- Информатика
- remove_red_eye 11151
- thumb_up 9
Ответы и объяснения 1
var a:array [1..100] of integer;
k,n,i:integer;
begin
clrscr;
write('Введите количество элементов массива=');
readln(n);
randomize;
for i:=1 to n do
a[i]:=random(45)-20;
writeln('Исходный массив');
for i:=1 to n do
write(a[i]:6);
writeln;
for i:=1 to n-1 do
if a[i+1]>a[i] then
writeln('Индексы: ',i:3);
writeln;
readln;
end.
- 24.01.2018 14:17
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.