Вопрос по информатике:
Помогите пожалуста составить программу в С++:
1. Записать собственную функцию вычисления модуля числа n modul (n) и использовать ее для вычисления среднего арифметического модулей трех произвольных чисел.
2. Создать функцию для вычисления длины отрезка, заданного координатами своих вершин на плоскости. Использовать эту функцию для вычисления периметра треугольника, заданного координатами своих вершин.
- 13.05.2018 05:10
- Информатика
- remove_red_eye 4921
- thumb_up 23
Ответы и объяснения 1
#include
#include
using namespace std;
struct VERT // структура для вершины многоугольника
{
int x;
int y;
};
// Модуль числа
int Modul( int a )
{
return (a > 0 ? a : -a);
}
// Длина отрезка через координаты
float Len( int x1, int y1, int x2, int y2 )
{
return sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
}
int main ()
{
/// ---- ЗАДАНИЕ 1 ---- ///
const int N = 3;
int arr[N];
float mid = 0;
// Установка "зерна" для случайных чисел
srand(time(NULL));
// Заполнение массива случайными числами и суммирование
for (int i = 0; i < N; i++)
arr[i] = rand() % 100, mid += Modul(arr[i]);
// Вычисление среднего арифм.
mid /= M;
/// ---- ЗАДАНИЕ 2 ---- ///
const int V = 3; // количество вершин многоугольника
VERT vert[V]; // массив вершин многоугольника
cout << "Введите координаты вершин (x y): " << endl;
for (int i = 0; i < V; i++)
{
cout << i + 1 << ": ";
cin >> vert[i].x >> vert[i].y;
}
// Вычисление периметра
float per = 0;
for (int i = 0; i < V - 1; i++)
per += Len(vert[i].x, vert[i].y, vert[i + 1].x, vert[i + 1].y);
cout << "Периметр = " << per << endl;
return 0;
}
- 14.05.2018 06:03
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.