Вопрос по информатике:
На языке Pascal напишите программу, которая будет подсчитывать количество двоек, четвёрок и пятёрок, полученных за контрольную работу по математике при условии если в классе 32 человека.
Исходные данные вводятся с клавиатуры с соблюдением правил дружественного интерфейса.
- 07.12.2015 07:45
- Информатика
- remove_red_eye 681
- thumb_up 38
Ответы и объяснения 2
A, i, k2, k4, k5, c, d, N: integer;
Begin
Write('Введите количество учеников в классе: ');ReadLn(N);
if (N = 32) then
Begin
c := 1;
d := 5;
WriteLn('Введите оценки учеников:');
k2 := 0;
k4 := 0;
k5 := 0;
i := 1;
While i <= N do
Begin
Write('Оценка ученика №',i,': ');ReadLn(A);
if (c <= A)and(A <= d) then
Begin
Case A of
2: k2 := k2+1;
4: k4 := k4+1;
5: k5 := k5+1;
End;
i := i+1;
End
else
WriteLn('Неприемлимое значение! Допустимые значения: [',c,'..',d,']');
End;
WriteLn('Количество двоек: ',k2);
WriteLn('Количество четвёрок: ',k4);
WriteLn('Количество пятёрок: ',k5);
End
else
WriteLn('В классе не 32 ученика');
End.
- 09.12.2015 01:40
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.