Вопрос по информатике:
Написать программу поиска суммы положительных чисел, вводимых с клавиатуры. Как
только будет введено отрицательное число, суммирование прекратить.
- 19.09.2018 12:30
- Информатика
- remove_red_eye 3894
- thumb_up 22
Ответы и объяснения 2
A,S: real;
Begin
S := 0;
Write('Введите последовательность чисел: ');
Read(A);
While A >= 0 do
Begin
S := S + A;
Read(A);
End;
WriteLn('S = ',S);
End.
- 20.09.2018 20:02
- thumb_up 23
//Версия 3.3, сборка 1611
begin
write(ReadSeqIntegerWhile(x->x>=0).Sum());
end.
- 21.09.2018 08:59
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.