Вопрос по информатике:
Задан массив A[1..17]. Составьте программу, которая выводит индексы тех элементов, значения которых равны нулю.
- 11.01.2018 03:00
- Информатика
- remove_red_eye 2904
- thumb_up 29
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(17,-5,5); a.Println;
var s:=a.IndexesOf(t->t=0);
if s.Count>0 then s.Select(t->t+1).Println
else Writeln('нет нулей')
end.
Пример
-3 -5 0 0 1 0 -5 2 1 -5 2 -1 2 -5 0 -5 2
3 4 6 15
- 12.01.2018 08:23
- thumb_up 8
a:array[1..17] of integer;
i:integer;
begin
for i:= 1 to 17 do
begin
read(a[i]);
if a[i] = 0 then
Write(i, ' ');
end;
end.
пример:
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6
1 11
- 13.01.2018 02:51
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.