Вопрос по информатике:
Помогите составить программу в паскале! Дано четырехзначное число. Найти а) сумму его цифр, б) произведение его цифр.
- 03.07.2018 04:16
- Информатика
- remove_red_eye 13411
- thumb_up 38
Ответы и объяснения 2
sum, com, n:integer;
begin
Read(n);sum:=0;com:=1;
while (n > 0) do begin
sum:= sum + n mod 10;
com:= com * (n mod 10);
n:= n div 10;
end;
Writeln('Сумма -> ', sum);
Writeln('Произведение -> ', com);
end.
Пример:
1234
Сумма -> 10
Произведение -> 24
- 04.07.2018 20:10
- thumb_up 20
//Версия 3.3, сборка 1611
begin
var a:=ReadInteger('введите число a=').ToString();
writeln('сумма цифр: ',a[1].ToDigit()+a[2].ToDigit()+a[3].ToDigit()+a[4].ToDigit());
write('произведение: ',a[1].ToDigit()*a[2].ToDigit()*a[3].ToDigit()*a[4].ToDigit());
end.
- 05.07.2018 17:40
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.