Вопрос по информатике:
Задание очень срочное!!! Нужно до 22.00 05.11.2015!!!
Написать программу, которая заменяет цифру числа названием этой цифры.
Например, заменить число 4563 на строку четыре пять шесть три.
ПАСКАЛЬ!!!
- 27.06.2018 20:27
- Информатика
- remove_red_eye 638
- thumb_up 16
Ответы и объяснения 1
Var
n: integer;
answer: string;
begin
read(n);
while n > 0 do {Пока есть цифры добавляем последнюю цифру числа к ответу и отбрасываем ее}
begin
case n mod 10 of
0: answer := 'ноль ' + answer;
1: answer := 'один ' + answer;
2: answer := 'два ' + answer;
3: answer := 'три ' + answer;
4: answer := 'четыре ' + answer;
5: answer := 'пять ' + answer;
6: answer := 'шесть ' + answer;
7: answer := 'семь ' + answer;
8: answer := 'восемь ' + answer;
9: answer := 'девять ' + answer;
end;
n := n div 10;
end;
writeln(answer);
end.
- 28.06.2018 15:57
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.