Вопрос по информатике:
Нужно написать программу
процедура сравнения типизированного файла(имя:f1.dat) и целочисленного массива.структура файла:х-целое
у-вещественное.
сравнение осуществляется поэлементно(1-ый элемент массива сравнивается со значением х 1-ой записи файла,....)если все значения совпали,то процедура возвращает строку true иначе false.
- 10.04.2018 18:59
- Информатика
- remove_red_eye 7984
- thumb_up 35
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
type
tt=record
x:integer;
y:real
end;
procedure Compare(f:file of tt; a:array of integer; var r:string);
begin
r:='true';
if f.FileSizea.Length then begin
Writeln('Размер массива не соответствует количеству записей файла');
r:='false';
exit
end;
f.Seek(0);
var t:tt;
for var i:=0 to a.Length-1 do begin
Read(f,t);
if t.xa[i] then begin
r:='false';
exit
end
end
end;
begin
var f:file of tt;
var n:=ReadInteger('n=');
Writeln('Введите ',n,' значений для сравнения');
var a:=ReadArrInteger(n);
var good:='';
Assign(f,'f1.dat'); Reset(f);
Compare(f,a,good);
Writeln(good);
f.Close
end.
Внимание! Поскольку входной файл не был представлен, программа не тестировалась! Проверена лишь компиляция программы.
- 11.04.2018 21:31
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.