Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность) . Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: разность максимального и минимального чисел.
Пример работы программы
Входные данные
8
-5
2
0
Выходные данные
13
НА С++
- 12.10.2017 11:27
- Информатика
- remove_red_eye 4223
- thumb_up 31
Ответы и объяснения 2
int main() { int a, mx, mn; cin >> a; mx = mn = a; cin >> a; while (a) { if (a > mx) mx = a; if (a > a; } cout << mx - mn << endl; return 0;}
- 13.10.2017 11:06
- thumb_up 18
using namespace std;
int main()
{
int Mx = -30001, Mn = 30001;
while (true){
int tmp;
cin >> tmp;
if (tmp == 0)
break;
Mn = min(tmp, Mn);
Mx = max(tmp, Mx);
}
cout << Mx - Mn;
}
- 14.10.2017 19:28
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.