Вопрос по информатике:
99б ПОМОГИТЕ СОСТАВИТЬ ПРОГРАММУ В PACALABC
ВОТ ЗАДАЧИ ПО МАССИВАМ:
Составить программу, которая формирует массив из 10 случайных целых чисел, принадлежащих
промежутку [-40;40], выводит элементы массива, а затем элементы массива на четных позициях
возводит в квадрат, а на нечетных позициях – заменяет элементы массива квадратом их индекса и вновь
выводит на экран все элементы массива.
16. Составить программу, которая формирует массив из 10 случайных целых чисел, принадлежащих
промежутку [-20;20], выводит элементы массива, а затем отрицательные числа возводит в квадрат, а из
неотрицательных извлекает квадратный корень и вновь выводит на экран все элементы массива.
17. В массив заполнить числа, отображающие зарплату за каждый месяц (Всего N месяцев). Найти общий
доход за N месяцев.
- 19.04.2016 03:31
- Информатика
- remove_red_eye 6435
- thumb_up 44
Ответы и объяснения 1
var
A: array [1..10] of integer;
i: integer;
begin
randomize;
write('Исходный массив: ');
for i := 1 to 10 do
begin
A[i] := random(81)-40;
write(A[i], ' ');
end;
writeln;
write('Измененный массив: ');
for i := 1 to 10 do
begin
if i mod 2 = 0 then A[i] := sqr(A[i])
else A[i] := sqr(i);
write(A[i], ' ');
end;
end.
//2
var
A: array [1..10] of real;
i: integer;
begin
randomize;
write('Исходный массив: ');
for i := 1 to 10 do
begin
A[i] := random(41)-20;
write(A[i], ' ');
end;
writeln;
write('Измененный массив: ');
for i := 1 to 10 do
begin
if A[i] < 0 then A[i] := sqr(A[i]);
if A[i] > 0 then A[i] := sqrt(A[i]);
write(A[i]:0:2, ' ');
end;
end.
//3
var
A: array [1..200] of real;
i, N: byte;
sum: real;
begin
write('Введите N = ');
readln(N);
sum := 0;
for i := 1 to N do
begin
write('З/П за ', i ,' месяц = ');
readln(A[i]);
sum := sum + A[i];
end;
writeln('Общий доход = ', sum:0:2);
end.
- 20.04.2016 21:31
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.