Вопрос по информатике:
Вариант 3.
1. Написать программу вычисления функции Y=x^2+sqrt(11+x/5+2x^2) для x∈[-3; 5]. Результат вывести в виде x=... y=...
2. Составить программу для нахожения M=S:14, где S - сумма всех двузначных чисел, кратных 5. Y= система 3x при x<=-5, x+5 при -5< x <= 4, 2x-1 при x>4.
3. для чисел от -7 до 8
- 17.06.2015 00:18
- Информатика
- remove_red_eye 9242
- thumb_up 20
Ответы и объяснения 2
var x:integer;
begin
for x:=-3 to 5 do
writeln('x = ',x:2,' y = ',x*x+sqrt((11+x)/(5+2*x*x)):6:4);
end.
Результат:
x = -3 y = 9.5898
x = -2 y = 4.8321
x = -1 y = 2.1952
x = 0 y = 1.4832
x = 1 y = 2.3093
x = 2 y = 5.0000
x = 3 y = 9.7802
x = 4 y = 16.6367
x = 5 y = 25.5394
2.
var i,s:integer;
begin
s:=0;
for i:=10 to 95 do
if i mod 5=0 then s:=s+i;
writeln('M = ',s/14:5:2);
end.
Результат:
M = 67.50
3.
var x,y:integer;
begin
for x:=-7 to 8 do
begin
if x<=5 then y:=3*x
else if x<=4 then y:=x+5
else y:=2*x-1;
writeln('x = ',x:2,' y = ',y);
end;
end.
Результат:
x = -7 y = -21
x = -6 y = -18
x = -5 y = -15
x = -4 y = -12
x = -3 y = -9
x = -2 y = -6
x = -1 y = -3
x = 0 y = 0
x = 1 y = 3
x = 2 y = 6
x = 3 y = 9
x = 4 y = 12
x = 5 y = 15
x = 6 y = 11
x = 7 y = 13
x = 8 y = 15
- 17.06.2015 23:25
- thumb_up 11
// Внимание! Если программа не работает, обновите версию!
begin
for var x:=-3 to 5 do
Writeln('x=',x:2,' y=',x*x+Sqrt((11+x)/(5+2*x*x)):0:5)
end.
Результат
x=-3 y=9.58977
x=-2 y=4.83205
x=-1 y=2.19523
x= 0 y=1.48324
x= 1 y=2.30931
x= 2 y=5.00000
x= 3 y=9.78019
x= 4 y=16.63671
x= 5 y=25.53936
----------------------------------------
begin
var M:=Range(10,99,5).Sum/14;
Writeln('M=',M)
end.
Результат
M=67.5
----------------------------------------
begin
var y:integer;
for var x:=-7 to 8 do begin
if x<=-5 then y:=3*x
else
if x>4 then y:=2*x-1
else y:=x+5;
Writeln('x=',x:2,' y=',y:3)
end
end.
Результат
x=-7 y=-21
x=-6 y=-18
x=-5 y=-15
x=-4 y= 1
x=-3 y= 2
x=-2 y= 3
x=-1 y= 4
x= 0 y= 5
x= 1 y= 6
x= 2 y= 7
x= 3 y= 8
x= 4 y= 9
x= 5 y= 9
x= 6 y= 11
x= 7 y= 13
x= 8 y= 15
- 18.06.2015 12:36
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.