Вопрос по информатике:
4. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 40.
var x, L, M: integer;
begin
readln(x);
L := x-10;
M := x+30;
while L <> M do
if L > M then
L := L - M
else
M := M – L;
writeln(M);
end.
- 25.05.2015 11:41
- Информатика
- remove_red_eye 9952
- thumb_up 25
Ответы и объяснения 1
var x, L, M: integer;
begin
for var i:=100 to 300 do
begin
x:=i
;L := x-10;
M := x+30;
while L M do
if L > M then
L := L - M
else
M := M - L;
If (M=40) then
begin
Println(x);
goto metka;
end;
end;
metka:
end.
- 26.05.2015 11:36
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.