Вопрос по информатике:
Напишите программу [на Pascal], которая вычисляет минимальное из трёх введённых чисел. Используйте функцию.
- 20.04.2015 17:55
- Информатика
- remove_red_eye 14207
- thumb_up 17
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
function Min3(a,b,c:real):=Min(a,Min(b,c));
begin
var (x,y,z):=ReadReal3('Введите три числа:');
Writeln('Минимальное: ',Min3(x,y,z))
end.
Пример
Введите три числа: 3.18 -2 5.7
Минимальное: -2
- 21.04.2015 13:41
- thumb_up 4
begin
if x
var a,b,c:integer;
begin
readln(a,b,c);
writeln('min = ',min(min(a,b),c));
end.
Пример:
8 2 5
min = 2
- 22.04.2015 07:46
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.