Вопрос по информатике:
Написать программу поиска номера элемента массива, принадлежащего заданному промежутку [1, 5], используя линейный поиск.Решить на Pascal ABC.
Пример:Линейный поиск элементов массива:
procedure poisk (z:omas; x:integer);
var i,p:byte;
begin
for i:=1 to n do
begin
if z[i]=x then p:=i;
end;
end;
- 23.08.2018 11:05
- Информатика
- remove_red_eye 19572
- thumb_up 15
Ответы и объяснения 1
Const n = 5;
var
i, p, x:byte;
z: array[1..n] of byte;
begin
readln(x);
for i:=1 to n do
begin
readln(z[i]);
if z[i]=x then p:=i;
end;
writeln(p);
end.
- 24.08.2018 22:45
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.