Вопрос по информатике:
Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если А>В>C>0, то замените все числа их квадратами и выведите результаты на экран. Если они отрицательны и не равны между собой, то каждое число замените наибольшим из них и выведите результаты. Иначе, найдите и выведите их сумму.
- 01.12.2015 02:25
- Информатика
- remove_red_eye 6514
- thumb_up 29
Ответы и объяснения 1
Var a,b,c,max:real;
begin
write('Введите a, b и c: ');
readln(a,b,c);
if (a>b) and (b>c) then
begin
a:=a*a;
b:=b*b;
c:=c*c;
writeln('a=',a,', b=',b,', c=',c);
end
else if (a<0) and (b<0) and (c<0) and (ab) and (ac) and (bc) then
begin
max:=a;
if b>max then max:=b;
if c>max then max:=c;
a:=max;
b:=max;
c:=max;
writeln('a=',a,', b=',b,', c=',c);
end
else writeln(a+b+c);
end.
- 02.12.2015 17:23
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.