Вопрос по информатике:
Написать программу определяющую, что точка принадлежит треугольнику на языке С координаты вершин треугольника(-1;0) (0;1) (1;0).
- 21.07.2015 09:13
- Информатика
- remove_red_eye 8074
- thumb_up 50
Ответы и объяснения 1
int main()
{
float x,y;
scanf("%f",&x);
scanf("%f",&y);
if (y>=0 && y<=-x+1 && y<=x+1) printf("YES");
else printf("NO");
return 0;
}
Пример:
-0.2 0.2
YES
- 22.07.2015 13:14
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.