Вопрос по информатике:
Помогите написать решение Паскаль в ALGO.
Задание 1) Для заданного X вычислить значение функций:
Y= 1) корень из X в квадрате, если x=2
2) "нет решений", если x=0
3) 3x в квадрате минус 5, если X=3,4,5,6.
Задание 2) - Составить алгоритм и программу
Написать программу, которая определяет по последней цифре числа последнюю цифру его квадрата.
Прошу написать полное решение программы,
Спасибо Заранее
- 25.12.2016 02:57
- Информатика
- remove_red_eye 7863
- thumb_up 52
Ответы и объяснения 1
1)
Var x:integer;
Begin
write('x=');
readln(x);
if x=2 then writeln('y=',sqrt(x*x))
else
if (x>=3)and(x<=6) then writeln('y=',(3*x*x-5))
else writeln('Решений нет');
End.
2)
Var x:integer;
Begin
write('x=');
readln(x);
x:=x mod 10;
writeln('Последняя цифра квадрата числа: ',x*x);
End.
- 26.12.2016 00:44
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.