Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет, есть ли в последовательности хотя бы одно четное число краmoе 3. Вход: программа получает на вход последовательность натуралыых чисел заканчивающимся нулем, количество чисел не превышает 1000, а сами числа 30000. Выход: программа должна вывести YES, если в последовательности есть четное число кратное 3 и NO в противном случае.
- 23.04.2015 03:02
- Информатика
- remove_red_eye 10831
- thumb_up 40
Ответы и объяснения 1
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
if ReadSeqIntegerWhile('Ввод завершите нулем:',t->t0).Any(t->t mod 6=0)
then Writeln('YES') else Writeln('NO')
end.
Примеры
Ввод завершите нулем: -45 34 23 17 -62 15 0
NO
Ввод завершите нулем: -45 34 23 17 -62 12 15 0
YES
Замечание. Количество вводимых чисел не ограничено, поскольку они в памяти не хранятся. Числа не должны превышать 2 147 483 647.
- 25.04.2015 00:54
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.