Вопрос по информатике:
Составьте программу которая заполняет массив b 1..8 случайными целыми числами в диапозоне от 1 до 10 затем изменяет знак элементов с чётными индексами на противоположный. выведите на экран исходный и полученный массивы
- 06.04.2018 01:26
- Информатика
- remove_red_eye 17873
- thumb_up 49
Ответы и объяснения 1
b: array[1..8] of integer;
i: byte;
begin
randomize;
writeln('Исходный массив.');
for i := 1 to 8 do
begin
b[i] := random(9)+1;
write(b[i], ' ');
end;
writeln;
writeln('Измененый массив.');
for i := 1 to 8 do
begin
if i mod 2 = 0 then b[i] := -b[i];
write(b[i], ' ');
end;
writeln;
end.
- 07.04.2018 18:39
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.