Вопрос по информатике:
Написать программу: Дано трехзначное число. Найти сумму цифр числа и определить является ли она четным числом.
- 20.10.2017 05:16
- Информатика
- remove_red_eye 15003
- thumb_up 42
Ответы и объяснения 1
var a, sum: integer;
begin
write('Введите число:'); readln(a);
while a 0 do
begin
sum := sum + (a mod 10);
a := a div 10;
end;
writeln('Сумма цифр = ', sum);
if sum mod 2 = 0 then writeln('Сумма четная')
else writeln('Сумма нечетная')
end.
- 22.10.2017 00:06
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.