Вопрос по информатике:
Написать программу, которая задает пользователю вопрос о том, какую фигуру тот выбирает: прямоугольник, или треугольник. После того, как пользователь выберет фигуру, программа интересуется, что он хочет найти для данной фигуры: площадь или периметр. После того, как пользователь выберет величину, которую хочет посчитать, программа запрашивает данные для подсчета величины данной фигуры.
на С++
- 11.11.2017 06:59
- Информатика
- remove_red_eye 4659
- thumb_up 11
Ответы и объяснения 1
using namespace std;
int main()
{
int n, k, a, b, c, h;
setlocale(LC_ALL, "rus");
cout << "Выберите фигуру \n";
cout << "1 - Треугольник \n";
cout << "2 - Прямоугольник \n";
cin >> n;
cout << "Площадь или периметр \n";
cout << "1 - Площадь \n";
cout << "2 - Периметр \n";
cin >> k;
if (n == 1) {
if (k == 1) {
cout << "Введите длину основания: ";
cin >> b;
cout << "Введите высоту: ";
cin >> h;
cout << "S = " << b * h * 0.5 << '\n';
}
if (k == 2) {
cout << "Введите 3 стороны:" << '\n' << "a: ";
cin >> a;
cout << '\n';
cout << "b:";
cin >> b;
cout << "/nc: ";
cin >> c;
cout << "P = " << a + b + c << '\n';
}
}
if (n == 2) {
if (k == 1) {
cout << "Введите длину: ";
cin >> a;
cout << "Введите ширину: ";
cin >> b;
cout << "S = " << a * b << '\n';
}
if (k == 2) {
cout << "Введите длину";
cin >> a;
cout << "Введите ширину: ";
cin >> b;
cout << "P = " << 2 * (a + b) << '\n';
}
}
}
- 12.11.2017 23:20
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.