Вопрос по информатике:
Написать программу в PascalABC.net
Удалить из строчки S символы + - *
А потом заменить все символы на символы следующие по алфавиту.
- 04.10.2017 19:11
- Информатика
- remove_red_eye 18395
- thumb_up 50
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите строку:');
s:=s.RegexReplace('[\+\-\*]',''); // удалили
s:=s.Select(c->Chr(Ord(c)+1)).JoinIntoString(''); // заменили
Writeln(s)
end.
Пример:
Введите строку: Мой пример: 23+18.4*(3.1-0.15)=52.7 Is it true?
Нпк!рсйнжс;!3429/5)4/21/26*>63/[email protected]
- 05.10.2017 14:44
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.