Вопрос по информатике:
Напишите программу, которая формирует случайным образом формирует одномерный массив размером 50 из целых чисел из интервала [-30...30], а затем определяет количество положительных чисел в массиве.
- 10.05.2018 08:44
- Информатика
- remove_red_eye 5281
- thumb_up 39
Ответы и объяснения 1
const n=50;
var a:array[1..n] of integer;
i,k:integer;
begin
for i:=1 to n do begin
a[i]:=RANDOM(61)-30;
write(a[i],' ');
end;
k:=0;
for i:=1 to n do
if a[i]>0 then k:=k+1;
writeln('количество положительных чисел массива=',k);
end.
- 11.05.2018 17:40
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.