Вопрос по информатике:
Напишите программу,в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел.Используйте оператор repeat. Решить в паскале.
- 20.01.2018 21:36
- Информатика
- remove_red_eye 7367
- thumb_up 63
Ответы и объяснения 1
Предполагается, что будет введено минимум одно значение.
var
max,a : integer;
begin
readln(a);
max := a;
repeat
readln(a);
if (a > max) and (a 0) then
max := a;
until a = 0;
writeln(max);
readln;
end.
P.S. Если понравилось решение не забудь отметить как лучшше. ;)
- 21.01.2018 15:42
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.