Вопрос по информатике:
Дан массив А[10]. Найти МАХ элемент среди элементов, стоящих на чётных местах и найденным значением заменить все элементы массива А, кратные 3. Преобразованный массив вывести на экран. Напишите программу на языке паскаль, спасибо!
- 04.03.2018 01:37
- Информатика
- remove_red_eye 2213
- thumb_up 10
Ответы и объяснения 1
CSize = 10;
var
m: array[1..CSize] of integer;
begin
randomize();
var max := -(MaxInt);
write('Исходный массив: ');
for var i := 1 to CSize do
begin
m[i] := random(100) + 1;
if (i mod 2 = 0) and (m[i] > max) then max := m[i];
write(m[i], ' ')
end;
write(NewLine, 'Преобразованный массив: ');
for var i := 1 to CSize do
begin
if m[i] mod 3 = 0 then m[i] := max;
write(m[i], ' ')
end
end.
- 05.03.2018 15:56
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.