Вопрос по информатике:
Слова в тексте разделены пробелом. Напишите программу, выводящая количество символов в каждом слове, через PascalABC.
- 16.11.2017 06:39
- Информатика
- remove_red_eye 19943
- thumb_up 10
Ответы и объяснения 1
var s,w:string; p:integer;
begin
readln(s);
s:=s+' ';
p:=pos(' ',s);
while p>0 do
begin
w:=copy(s,1,p-1);
writeln(w,' - ',length(w));
delete(s,1,p);
p:=pos(' ',s);
end;
end.
Пример:
Слова в тексте разделены пробелом
Слова - 5
в - 1
тексте - 6
разделены - 9
пробелом - 8
2)
var s,w:string; k,i:integer;
begin
readln(s);
s:=s+' ';
w:=''; k:=0;
for i:=1 to length(s) do
if s[i]' ' then begin w:=w+s[i]; k:=k+1; end
else begin writeln(w,' - ',k); w:=''; k:=0; end;
end.
- 17.11.2017 10:51
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.