Вопрос по информатике:
40 баллов СРООООООЧЧЧЧННОООО!!!
ПОМОГИТЕ СДЕЛАТЬ ПАСКАЛЬ ПОЖАЛУЙСТА
1.Составьте программу, которая вычисляет сумму всех нечетных, двузначных чисел;
2.Дано натуральное число n. Вычислите n5;
3.Дано число n. Напечатать натуральные числа, квадрат которых не превышает n.
- 14.01.2017 08:32
- Информатика
- remove_red_eye 17843
- thumb_up 37
Ответы и объяснения 2
var
i: byte;
sum: integer;
begin
sum := 0;
i := 11;
while i < 100 do
begin
sum := sum + i;
i := i + 2;
end;
writeln('Сумма нечетных элементов = ', sum);
readln;
end.
---------------------------------------------------------
2)
var
n: real;
begin
write('Введите n: ');
readln(n);
n := exp(ln(n) * 5);
writeln(n);
readln;
end.
------------------------------------------------
3)
var
n: integer;
i: integer;
begin
write('Введите n: ');
readln(n);
i := 0;
for i := 1 to n do
if sqr(i) <= n then
write(i, ' ')
else
break;
readln;
end.
- 15.01.2017 12:23
- thumb_up 15
var s,i:integer;
begin
s:=0;
for i:=10 to 99 do
if i mod 2=1 then s:=s+i;
writeln('s = ',s);
end.
Результат:
s = 2475
2. Без использования стандартных функций:
var n,p,i:integer;
begin
readln(n);
p:=1;
for i:=1 to 5 do p:=p*n;
writeln(n,'^5 = ',p);
end.
Пример:
2
2^5 = 32
3.
var n,i:integer;
begin
readln(n);
i:=1;
while i*i
writeln(i,' (',i,'^2 = ',i*i,')');
i:=i+1;
end;
end.
Пример:
30
1 (1^2 = 1)
2 (2^2 = 4)
3 (3^2 = 9)
4 (4^2 = 16)
5 (5^2 = 25)
- 16.01.2017 09:34
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.