Вопрос по информатике:
Составить программу, которая формирует массив из 12 случайных чисел, принадлежащих промежутку [-10,10], заменяет все отрицательные числа положительными, а положительные заменяет на ноль.
- 08.11.2017 11:25
- Информатика
- remove_red_eye 7068
- thumb_up 15
Ответы и объяснения 1
const n=12;
var A:array[1..n] of integer;
var i:integer;
begin
randomize;
for i:=1 to n do
begin
A[i]:=Random(21) -10;
write(A[i], ' ');
end;
for i:=1 to n do
begin
if (A[i]<0) then
A[i]:=A[i]*(-1)
else
A[i]:=0;
write(A[i],' ');
end;
end.
- 09.11.2017 05:07
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.