Вопрос по информатике:
Напишите программу для решения следующей задачи.Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов.Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ. Пример работы программы:Входные данные 4 15 12 0 17 Выходные данные 17 YES
- 28.05.2018 00:26
- Информатика
- remove_red_eye 10332
- thumb_up 19
Ответы и объяснения 1
N, i, max: shortint;
arr: array[1..50] of shortint;
v: string;
begin
v := ' NO';
max := -(MaxSmallInt);
readln(N);
for i := 1 to N do
begin
read(arr[i]);
if arr[i] > max then max := arr[i];
if arr[i] = 0 then v := ' YES';
end;
writeln(max, v);
end.
- 28.05.2018 04:47
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.