Вопрос по информатике:
C++.Совершенным называется число, равное сумме всех своих делителей, меньших его самого (например, число 6=1+2+3). Напишите программу, которая вводит натуральное число N и определяет, является ли число N совершенным.
- 24.12.2017 23:12
- Информатика
- remove_red_eye 9744
- thumb_up 30
Ответы и объяснения 1
using namespace std;
bool perfect_number(int n)
{
int res = 1;
for (int i = 2; i * i <= n; ++i)
if (n % i == 0)
res += i + n / i;
return res == n?1:0;
}
int main()
{
int n;
cin >> n;
cout << perfect_number(n)?"YES":"NO";
}
- 25.12.2017 15:48
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.