Вопрос по информатике:
Написать программу в С++ Дано натуральное число. Определить, сколько раз в нём встречается максимальная цифра.
- 17.04.2018 04:26
- Информатика
- remove_red_eye 13911
- thumb_up 13
Ответы и объяснения 1
using namespace std;
int A[20];
int main()
{
int n, c, p, max;
int counter, ncounter;
counter = 0;
cin >> n;
c = n;
p = n;
for (c; c>0;)
{
counter++;
c = c / 10;
A[counter] = p - c * 10;
p = c;
if (c > 0 && c < 10)
{
A[counter + 1] = c;
}
}
max = 0;
ncounter = 0;
for (int s = 1; s <= counter; s++)
{
if (A[s] > max)
{
max = A[s];
ncounter = 0;
}
if (A[s] == max)
{
ncounter++;
}
}
cout << ncounter;
system("pause");
return 0;
}
- 18.04.2018 20:40
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.