Вопрос по информатике:
Программа на с++
Напишите программу, которая находит номер максимального элемента массива.
Входные данные
В первой строке задается одно натуральное число N, не превосходящее 1000 – размер массива.
Во второй строке вводится N чисел – элементы массива (целые числа, не превосходящие по модулю 1000).
Выходные данные
Вывести одно число – номер максимального элемента в массиве. Если в массиве несколько максимальных элементов, выведите номер любого из них.
Примеры
входные данные
5
5 4 3 2 1
выходные данные
1
- 01.06.2018 20:20
- Информатика
- remove_red_eye 3930
- thumb_up 21
Ответы и объяснения 1
using namespace std;
int main() {
int n;
cin >> n;
short *arr = new short[n];
for (int i = 0; i < n; i++) {
cin >> arr[i];
}
int max = arr[0];
for (int i = 0; i < n; i++) {
if (arr[i] > max) {
max = arr[i];
}
}
cout << max;
return 0;}
- 02.06.2018 06:19
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.