Вопрос по информатике:
Напишите программу которая сравнивает три числа и выводит произведение двух наименьших
- 16.04.2018 22:52
- Информатика
- remove_red_eye 2882
- thumb_up 50
Ответы и объяснения 1
#include
#include
using namespace std;
int GetMin(vector arr, int &index)
{
int min = arr[0];
index = 0;
for (int i = 0; i < arr.size(); i++)
{
if (arr[i] < min)
{
index = i;
}
}
return arr[index];
}
int main()
{
vector n;
n.resize(3);
cin >> n[0] >> n[1] >> n[2];
int i = 0;
int min1 = GetMin(n, i);
n.erase(n.begin() + i);
int min2 = GetMin(n, i);
cout << min1 * min2;
cin >> n[0];
return 0;
}
- 17.04.2018 09:01
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.