Вопрос по информатике:
. Составить программу для нахождения и печати всех Пифагоровых чисел, не превышающих 20.
- 04.07.2016 08:04
- Информатика
- remove_red_eye 8532
- thumb_up 11
Ответы и объяснения 1
Пифагоровыми числами называются числа, для которых выполняется равенство a²+b²= c².
//Pascal
var
i, j, k: integer;
begin
for i := 1 to 20 do
for j := i to 20 do
for k := j to 20 do if i * i + j * j = k * k then writeln(i:4, j:4, k:4);
end.
- 05.07.2016 01:06
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.